Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 59
  1. #31
    Newbie
    Join Date
    Aug 2008
    Posts
    8

    Default

    Hi. I'm trying to fix (had this working before upgrading) the ssh. After I upgraded it just stopped working. Haven't messed with any settings, firewall, protocol or anything recently. One weird thing is that I can connect ssh if I connect via another network (outside, not lan). but the second i try to connect lan i get the error ssh_exchange_identification ... remote host closed connection...

    I been on this forum searching for this problem, however other people fix isn't working for me.

  2. #32
    Master Untangler RiffRaff's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis, Indiana, USA
    Posts
    158

    Default

    This worked great for me on version 6.0.2.

    Thanks!


  3. #33
    Untangle Ninja juank's Avatar
    Join Date
    Aug 2007
    Location
    Athens
    Posts
    1,413

    Default

    Quote Originally Posted by igpf View Post
    Hi. I'm trying to fix (had this working before upgrading) the ssh. After I upgraded it just stopped working. Haven't messed with any settings, firewall, protocol or anything recently. One weird thing is that I can connect ssh if I connect via another network (outside, not lan). but the second i try to connect lan i get the error ssh_exchange_identification ... remote host closed connection...

    I been on this forum searching for this problem, however other people fix isn't working for me.
    Is everything working as expected? I am asking because your error sounds like you need to swap your INTERNAL and EXTERNAL cables
    --------------------------------
    Juan Machado
    --------------------------------

  4. #34
    Master Untangler Drewster727's Avatar
    Join Date
    Jan 2009
    Posts
    163

    Default

    ya know it's very strange...recently while testing ssh from an off site pc I have some issues blocking the incomging ssh requests.

    I have ran through the terminal commands to get ssh working on UT's startup, etc..

    What I want is to block any requests to SSH into my network, but the strange thing is...when I remote into an off site pc and ssh into my router it actually lets me without any port forwards or rules to allow access...that seems a bit insecure to me.

    --now I thought to myself "oh wait" I have port 22 in my port forward list, but it is not enable....no matter when it is on or off, my off site pc can still gain access. Now I did create a packet filter rule to block all ssh, but should I really have to do this?

    I do have the firewall node installed but for the time being it is set to pass traffic by default...yet even when I go into the firewall node and block any and all traffic coming in or out on port 22...my off site pc still can connect and ssh into UT.

    does this sound strange at all? or am I just missing something. --as a side note...I did edit the sshd_config file and designated my listening address to UTs internal ip (192.168.1.1). yet...if I do not designate that packet filter rule...I can still connect on port 22 to ssh into UT.

    So! I suppose what I'm saying is how can I effectively limit all SSH traffic on the default port of 22 to my internal network. AND why when I make firewall rules and remove port forwards for port 22 can I still connect on port 22 to my UT router through ssh????

    thanks in advance for any info on this, sorry to repeat stuff if this has been mentioned before...I did some searching and did not seem to find anyone with a problem like this.

  5. #35
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    26,491

    Default

    Yes you have to create a packet filter rule to control SSH. It's been this way for almost a year and is well documented in this thread as well as others. The behavior annoys me too but that is just the way that it is.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  6. #36
    Master Untangler Drewster727's Avatar
    Join Date
    Jan 2009
    Posts
    163

    Default

    ok cool, well at least I'm not the only one!

  7. #37
    Newbie
    Join Date
    Apr 2009
    Posts
    2

    Default

    i have just gotten my UT 6.1 running and as i was try to get the ssh to work, i've accidentally deleted the '/etc/init.d/ssh ' how do i reinstall it back?

    thank you in advance.

  8. #38
    Untangler
    Join Date
    Apr 2009
    Posts
    40

    Default

    how to enable external administration via webinterface ? so that i can make ww.untagle.com:77777 to configure it? (not SSH)

  9. #39
    Untangle Ninja
    WebFooL's Avatar
    Join Date
    Jan 2009
    Location
    Sweden (Eskilstuna)
    Posts
    5,042

    Default

    Hi snapo,

    Go to Config>Administration.
    Check the "Enable External Administration"
    If you want port 77777 change "External HTTPS port" from 443 to 77777.

    Or did you want to enable the ssh thru the webgui on port 77777?

  10. #40
    Untangler
    Join Date
    Nov 2008
    Posts
    83

    Default

    I did a clean install of 6.1 and now when I try to install SSH i get the following error:
    OpenBSD Secure Shell server not in use (/etc/ssh/sshd_not_to_be_run)
    Has anyone seen this, how can I resolve the issue so as to enable ssh?

Page 4 of 6 FirstFirst ... 23456 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2