Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    Welcome to the forums!

    The default time is 5 minutes. If you want to change it to something else you can do it in /etc/default/ddclient. In the file it is specified in seconds.

    How it works is, every 5 minutes, it checks what is in /var/cache/ddclient/ddclient.cache. If the address is the same as what the cache file has then it does not update with your dyndns provider. If the address is different in that cache file, it updates it.

  2. #12
    zal
    zal is offline
    Untangler
    Join Date
    Mar 2008
    Posts
    41

    Default

    Thanks for your reply Silver, my untangle box isn't updating to dyndns I have fulled all the details correctly. I have logged into dyndns and it hasn't been updated for two days

    I'm new to Linux, what can I do?

  3. #13
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    Open the terminal and run this command and post any errors
    ddclient --verbose

  4. #14
    zal
    zal is offline
    Untangler
    Join Date
    Mar 2008
    Posts
    41

    Default

    I only have remote access, tried shh but I haven't enable it

  5. #15
    zal
    zal is offline
    Untangler
    Join Date
    Mar 2008
    Posts
    41

    Default

    ~ # ddclient -verbose
    CONNECT: checkip.dyndns.com
    CONNECTED:
    SENDING: GET / HTTP/1.0
    SENDING: Host: checkip.dyndns.com
    SENDING: User-Agent: ddclient/3.6.2
    SENDING: Connection: close
    SENDING:
    RECEIVE: HTTP/1.1 200 OK
    RECEIVE: Content-Type: text/html
    RECEIVE: Server: DynDNS-CheckIP/1.0
    RECEIVE: Connection: close
    RECEIVE: Cache-Control: no-cache
    RECEIVE: Pragma: no-cache
    RECEIVE: Content-Length: 105
    RECEIVE:
    RECEIVE: <html><head><title>Current IP Check</title></head><body>Current IP Address: 122.57.10.xxx</body></html>
    INFO: setting IP address to 122.57.10.xxx for xxx
    UPDATE: updating peg
    CONNECT: members.dyndns.org
    CONNECTED:
    SENDING: GET /nic/update?system=dyndns&hostname=peg&myip=122.57.10.xxx HTTP/1.0
    SENDING: Host: members.dyndns.org
    SENDING: Authorization: Basic YWlzZWN1cml0eTphbWNsMzc=
    SENDING: User-Agent: ddclient/3.6.2
    SENDING: Connection: close
    SENDING:
    RECEIVE: HTTP/1.1 200 OK
    RECEIVE: Date: Mon, 07 Apr 2008 00:05:57 GMT
    RECEIVE: Server: Apache
    RECEIVE: X-UpdateCode: X
    RECEIVE: Content-Length: 7
    RECEIVE: Connection: close
    RECEIVE: Content-Type: text/plain
    RECEIVE:
    RECEIVE: notfqdn
    FAILED: updating peg: notfqdn: A Fully-Qualified Domain Name was not provided
    ~ #





    DynDNS says last update was 1 of april

  6. #16
    Untangle Ninja Silver Bullet's Avatar
    Join Date
    Sep 2007
    Posts
    1,946

    Default

    FAILED: updating peg: notfqdn: A Fully-Qualified Domain Name was not provided
    Did you enter the fully qualified domain name in the dyndns settings? That is implying that you haven't. You will need to enter it just as you access it remotely.

  7. #17
    zal
    zal is offline
    Untangler
    Join Date
    Mar 2008
    Posts
    41

    Default

    Thanks for your reply Silver.
    I have just setup a new host, entered all the details.
    Now I am getting this?
    I am guessing this means it has nothing to update being the ip hasn't changed?

    thanks for your help.


    CONNECTED:
    SENDING: GET / HTTP/1.0
    SENDING: Host: checkip.dyndns.com
    SENDING: User-Agent: ddclient/3.6.2
    SENDING: Connection: close
    SENDING:
    RECEIVE: HTTP/1.1 200 OK
    RECEIVE: Content-Type: text/html
    RECEIVE: Server: DynDNS-CheckIP/1.0
    RECEIVE: Connection: close
    RECEIVE: Cache-Control: no-cache
    RECEIVE: Pragma: no-cache
    RECEIVE: Content-Length: 105
    RECEIVE:
    RECEIVE: <html><head><title>Current IP Check</title></head><body>Current IP Add ress: 122.57.10.xxx</body></html>
    WARNING: skipping update of peguntangle from <nothing> to 122.57.10.xxx.
    WARNING: last updated <never> but last attempt on Mon Apr 7 14:59:29 2008 fai led.
    WARNING: Wait at least 5 minutes between update attempts.

  8. #18
    zal
    zal is offline
    Untangler
    Join Date
    Mar 2008
    Posts
    41

    Default

    I've fixed it
    Silly really.

    Under host name you have to xyz.dnsdojo.com and have the dnsdojo.com in the suffix. I only had xyz as the host name, didn't have dnsdojo at the end.

    Annoying really as it was so easy.

  9. #19
    mdh
    mdh is offline
    Untangle Ninja mdh's Avatar
    Join Date
    Aug 2007
    Posts
    4,752

    Default

    You live.
    You bang your head against the wall.
    You learn.
    Glad you got it!

  10. #20
    zal
    zal is offline
    Untangler
    Join Date
    Mar 2008
    Posts
    41

    Default

    lol well said

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2