I've set mine from English to Korean.
Entering reports from normal login, (ie. https://<IP>/) you get the translated report page.
reports-1.PNG

However entering reports directly, (ie. https://<IP>/reports) you DO NOT get the translated report page.
reports-2.PNG

Is there any setting for reports separately?