Results 1 to 7 of 7
  1. #1
    Master Untangler
    Join Date
    Dec 2018
    Posts
    108

    Default Private Internet Access tunnel and block-outside-dns question

    Is it possible to use this on my PIA tunnel? I use it on my client connections from my phone/PC, but adding that line to the .ovpn file causes the tunnel to never connect.

    An example would be greatly appreciated as I just followed the instructions on the Add Tunnel screen and used the iOS templates.

  2. #2
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    7,840

    Default

    Yes, use Tunnel VPN app on Untangle with your VPN provider.

    https://wiki.untangle.com/index.php/Tunnel_VPN
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  3. #3
    Master Untangler
    Join Date
    Dec 2018
    Posts
    108

    Default

    Can you be a bit more specific on the section that addresses my issue?

    I have the Tunnel VPN tunnel set up and working already to PIA, however, I can't seem to force any device on my network to use the PIA DNS servers. They all just use what I have set up on my WAN connection.

    With the OpenVPN tunnel that I have set up so that I can get into my own network from outside I used the "block-outside-dns" to force the use of the DNS server that I wanted, however, with the Tunnel VPN config file I can't add that option or it won't connect to PIA.

    Is there a specific spot in the .ovpn file that I need to put that option?

  4. #4
    Newbie
    Join Date
    Jan 2019
    Posts
    2

    Default

    Quote Originally Posted by jlficken View Post
    Can you be a bit more specific on the section that addresses my issue?

    I have the Tunnel VPN tunnel set up and working already to PIA, however, I can't seem to force any device on my network to use the PIA DNS servers. They all just use what I have set up on my WAN connection.

    With the OpenVPN tunnel that I have set up so that I can get into my own network from outside I used the "block-outside-dns" to force the use of the DNS server that I wanted, however, with the Tunnel VPN config file I can't add that option or it won't connect to PIA.

    Is there a specific spot in the .ovpn file that I need to put that option?
    Did you ever get this to work?

  5. #5
    Master Untangler
    Join Date
    Dec 2018
    Posts
    108

    Default

    Quote Originally Posted by apexav View Post
    Did you ever get this to work?
    Kind of but not exactly how I'd like it to work.


    I wound up just tagging specific devices to use the VPN and then did a port forwarding rule to redirect the DNS request to the DNS server of my choosing if they weren't using it.

    I can post some pictures if you want?

  6. #6
    Newbie
    Join Date
    Jan 2019
    Posts
    2

    Default

    Quote Originally Posted by jlficken View Post
    Kind of but not exactly how I'd like it to work.


    I wound up just tagging specific devices to use the VPN and then did a port forwarding rule to redirect the DNS request to the DNS server of my choosing if they weren't using it.

    I can post some pictures if you want?
    yes please... would love to see how this is done.

  7. #7
    Master Untangler
    Join Date
    Dec 2018
    Posts
    108

    Default

    Quote Originally Posted by apexav View Post
    yes please... would love to see how this is done.


    This is how I did it. It works but I wish it was a bit less involved. I never could get the Port Forwarding Rule to work just selecting the PIA interfaces so I had to use tagging.

    ETA: Just realized I forgot to set TCP on the protocol as well so I fixed that.
    Attached Images Attached Images
    Last edited by jlficken; 01-29-2019 at 07:35 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2