Results 1 to 8 of 8
  1. #1
    Newbie
    Join Date
    Jan 2010
    Posts
    6

    Default ftp large file upload is corrupted

    I can't quite tell if the other extensive thread about downloads and ftp corruption was resolved.
    I have the opposite finding, uploading a file from my computer, through UT, to a server, with ftp, always corrupts a file larger than about 30Mbyte.
    I have Untangle build 8.1.1.

    I can turn off the Virus Blocker and the transfer is fine.
    The failure symptom, using FileZilla is always the same: the transfer counts down to completion, then FileZilla pauses about 10 seconds (longer than normal), then declares an error and restarts the tail end of the transfer, about the last 10%. FileZilla then runs to completion again, however the destination file is now a different size than the actual file. Can be larger or smaller.
    And the content is corrupted at that end portion (its a video file).

    Well, I have a simple workaround, disable Virus Blocker during upload.
    Is there any other data I can collect which would help to diagnose this?

    I have used a different ftp client with similar corruption results.
    Thanks, Rich

  2. #2
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    25,095

    Default

    The AV corruption issue is a long standing one. It happens when the AV module attempts to scan the file, but can't get done before the network times out.

    So you either get a faster CPU to scan the file faster, or you create a bypass rule for each FTP server you need to use.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  3. #3
    Untangle Junkie dmorris's Avatar
    Join Date
    Nov 2006
    Location
    San Carlos, CA
    Posts
    17,747

    Default

    You just need to increase your timeout to over 30 seconds.
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Newbie
    Join Date
    Jan 2010
    Posts
    6

    Default

    Thanks, bypass worked great !!
    Would be nice if the AV module performed scanning in a "streaming" fashion. Do the scan as the data moves. After all, the data transfer rates are usually so, so slow.
    Feature request!
    Thanks, Rich

  5. #5
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    25,095

    Default

    That is rather hard to do, a file needs to be complete and intact for a signature comparison to be performed.

    I hadn't considered turning up the time out... so obvious.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  6. #6
    Untanglit
    Join Date
    Apr 2008
    Posts
    28

    Default

    Where can I change timeout settings?

  7. #7
    Untangle Ninja sky-knight's Avatar
    Join Date
    Apr 2008
    Location
    Phoenix, AZ
    Posts
    25,095

    Default

    It's in your FTP client, not Untangle. Dig around in the preferences, until you find it.
    Rob Sandling, BS:SWE, MCP
    NexgenAppliances.com
    Phone: 866-794-8879 x201
    Email: support@nexgenappliances.com

  8. #8
    Newbie BGE123's Avatar
    Join Date
    Apr 2011
    Location
    Illinois, USA
    Posts
    1

    Default

    How to configure FTP?













    __________________

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2