Results 1 to 4 of 4
  1. #1
    Newbie
    Join Date
    May 2018
    Posts
    11

    Default Web Filter using UT's IP instead of Hostname

    Hello, I have a minor problem with Web Filter.

    I've installed a proper SSL certificate (Let's Encrypt) which is tied to the domain name that I've assigned to UT. I can visit the UT Admin page using HTTPS no problem. However, apps like Web Filter still sends users to its non-encrypted private IP, which creates browser security warnings. I've set Config->Network->Hostname to "Use Hostname", but that doesn't appear to affect Web Filter.

    How can I force web filter to use UT's hostname and use SSL (When redirecting from SSL)?


    Clarification: Web Filter IS working, I just want to make sure that if anyone goes to a blocked HTTPS page, that they don't get confused with security warnings and see the UT Web Filter 'blocked' page instead.

  2. #2
    Newbie
    Join Date
    May 2018
    Posts
    11

    Default

    Update: SSL inspector was turned off, I turned it on and so far I haven't encountered any SSL errors. I'll test this further once I'm home (Can only test while on my phone at work).

  3. #3
    Untangler jcoffin's Avatar
    Join Date
    Aug 2008
    Location
    Sunnyvale, CA
    Posts
    7,620

    Default

    Quote Originally Posted by SeanATron View Post
    How can I force web filter to use UT's hostname and use SSL (When redirecting from SSL)?
    You can't. It does not matter either way since the browser is giving an SSL error is the redirect page (block page) is not the page requested (example google.com).
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email support@untangle.com

  4. #4
    Newbie
    Join Date
    May 2018
    Posts
    11

    Default

    Quote Originally Posted by jcoffin View Post
    You can't. It does not matter either way since the browser is giving an SSL error is the redirect page (block page) is not the page requested (example google.com).
    The SSL error is because the name doesn't match the certificate. It redirects without issue. Since 192.168.1.1 != hostname, it creates an SSL error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

SEO by vBSEO 3.6.0 PL2